Opened 8 years ago

Closed 7 years ago

#15286 closed defect (worksforme)

EnhancedGrid row alignment broken on Chrome 18.0.1025.168 m

Reported by: roentgen Owned by: Evan
Priority: undecided Milestone: 1.9
Component: DojoX Grid Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

When I have a grid with hundreds of rows and then I scroll downwards very fast the row alignment breaks between the noscroll columns and the columns that are horizontally scrollable. The noscroll columns end up about half a row height below the horizontally scrollable columns on the same row. This happens about 1/3 of the time that I scroll downwards very fast and I can trigger it both with the mouse wheel and by dragging the scroll position indicator.

This bug manifests on Chrome 18.0.1025.168 m on Windows.

This does not happen in Firefox 10.0 on Linux or IE 8 on Windows.

Attachments (2)

grid_scroll_broken_on_chrome.png (5.2 KB) - added by roentgen 8 years ago.
screenshot
15286.html (2.8 KB) - added by Evan 7 years ago.
Adding a test case running well for me in Chrome v23, tested with dojo v 1.7+

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by roentgen

screenshot

comment:1 Changed 8 years ago by Adam Peller

Owner: changed from dante to Evan
Status: newassigned

comment:2 Changed 8 years ago by Adam Peller

Component: DojoX WidgetsDojoX Grid

comment:3 Changed 7 years ago by Evan

Milestone: tbd1.9
Resolution: worksforme
Status: assignedclosed

Not able to reproduce this issue anymore in the latest Chrome(v23), also uploading a test case running well for me - with 1000 rows, 1 noscroll view + 1 scroll view.

Changed 7 years ago by Evan

Attachment: 15286.html added

Adding a test case running well for me in Chrome v23, tested with dojo v 1.7+

Note: See TracTickets for help on using tickets.