Opened 7 years ago

Closed 7 years ago

#15284 closed defect (fixed)

ColorPalette: tooltips always in english (IE7)

Reported by: bill Owned by: bill
Priority: undecided Milestone: 1.8
Component: Dijit Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

Using test page /dijit/tests/test_ColorPalette.html:

  1. Set your IE7 browser to French (or any other language but English).
  2. Load the page
  3. Using the last ColorPalette control, go over the colors.

Result:

  • If your mouse is on the border, the tooltip will be localized.
  • If your mouse is on the color, the tooltip will be in English.

This is in IE7 or IE9 Compatibility View with IE7 mode.

This is caused by the 'alt' attribute on the <img> for the color. It's in English. Other browsers will use the 'title' attribute instead.

Change History (2)

comment:1 Changed 7 years ago by bill

Milestone: tbd1.8
Owner: set to bill
Status: newassigned

comment:2 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

In [28474]:

Localize alt and title attribute on <img> node, to prevent tooltip on IE7 being English.

Removed the BIDI tests for ColorPalette direction since it turns out there's no requirement about which direction the colors display in RTL mode.

Fixes #15284 !strict.

Note: See TracTickets for help on using tickets.