Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#15276 closed defect (fixed)

exception in test_enhanced_grid_pagination.html

Reported by: bill Owned by: Evan
Priority: undecided Milestone: 1.7.4
Component: DojoX Grid Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

On firefox with firebug, run test_enhanced_grid_pagination.html, and then click on a number on the bottom of the grid like "30". It gets an exception in dojo.stopEvent(evt) because evt is undefined.

Worked in 1.6, started failing in 1.7.

Change History (5)

comment:1 Changed 7 years ago by Evan

Milestone: tbd1.8
Resolution: worksforme
Status: newclosed

Working well, not reproduced in the latest trunk and 1.7.x branch(testing on FF12), so closing as 'worksforme'

comment:2 Changed 7 years ago by bill

Resolution: worksforme
Status: closedreopened

Not sure why you can't reproduce it, but it's still broken, and easy to see from the code. Pagination.onActive is:

_onActive: function(e){
        this._focusedNode = e.target;
        if(!this._isFocused){
                this._pager.plugin.grid.focus.focusArea('pagination' + this._pager.position);
        }
},

It's calling focusArea() with only one argument, but focusArea takes two:

focusArea: function(/* int|string|areaObj */areaId,evt){
        var idx;
        if(typeof areaId == "number"){
                idx = areaId < 0 ? this._areaQueue.length + areaId : areaId;
        }else{
                idx = array.indexOf(this._areaQueue,
                        lang.isString(areaId) ? areaId : (areaId && areaId.name));
        }
        if(idx < 0){ idx = 0; }
        var step = idx - this._currentAreaIdx;
        this._gridBlured = false;
        if(step){
                this.tab(step, evt);
        }else{
                this.currentArea().onFocus(evt, step);
        }
},

comment:3 Changed 7 years ago by Evan

Resolution: fixed
Status: reopenedclosed

In [29241]:

Fixes #15276 !strict, a sane check before stopEvent()

comment:4 Changed 7 years ago by Evan

In [29242]:

Refs #15276 !strict, also back port to 1.7.x branch

comment:5 Changed 7 years ago by Evan

Milestone: 1.81.7.4
Note: See TracTickets for help on using tickets.