Opened 8 years ago

Closed 8 years ago

#15223 closed defect (duplicate)

In IE9 the editor overwrites width and height attributes on images

Reported by: DJ Mountney Owned by:
Priority: undecided Milestone: tbd
Component: Editor Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

Go to editor tutorial demo in IE9 here: http://dojotoolkit.org/documentation/tutorials/1.7/editor/demo/editor-dijit-plugins.html

Jump into source view and paste in <img alt="foo" src="http://dojotoolkit.org/dojango/dojo-media/dtk/images/page-title-smaller.png" width="300" />

Then toggle back to normal mode, then back to source mode. Notice width is now contains "foo" instead of 300. If you go back to normal mode, the image is no longer visible.

Also, if you remove the alt="foo", width will be removed as well.

I've tested this in an editor will no plugins, and the behavior was the same (when getting the value).

This does not repro in IE7 or IE8.

Tested on 1.6.1 and whatever 1.7.x that demo page is running.

Change History (2)

comment:1 Changed 8 years ago by DJ Mountney

comment:2 Changed 8 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #15032.

Note: See TracTickets for help on using tickets.