Opened 8 years ago

Closed 8 years ago

#15203 closed defect (fixed)

Abnomal behavior of A Bottom TabBar with Heading, SwapView, TabBar combination

Reported by: youngho Owned by: ykami
Priority: high Milestone: 1.8
Component: DojoX Mobile Version: 1.7.2
Keywords: Cc: Eric Durocher
Blocked By: Blocking:

Description

Hello

A screen which have top dojox.mobile.Heading, middle dojox.mobile.SwapView?, bottom dojox.mobile.TabBar?

when forward SwapView? shows TabBar? normally, but when backward SwapView?, the TabBar? shows abnormally.

I attached a test case file.

Attachments (1)

test_SwapView-slideshow_1.html (4.0 KB) - added by youngho 8 years ago.

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by youngho

comment:1 Changed 8 years ago by ykami

Cc: Eric Durocher added
Milestone: tbd1.8
Priority: undecidedhigh
Status: newassigned

Thank you for finding this. Looks like this is a bug of SwapView.

comment:2 Changed 8 years ago by ykami

Resolution: fixed
Status: assignedclosed

In [28384]:

Fixes #15203 Override findDisp() to return the current view. The original findDisp() returns a wrong view when you swipe a SwapView? backward, because it simply returns the first visible view. !strict

comment:3 Changed 8 years ago by Damien Mandrioli

This fix creates a regression in the mobile gallery. Choosing "Swap View" in the gallery displays a blank screen.

comment:4 in reply to:  3 Changed 8 years ago by ykami

Resolution: fixed
Status: closedreopened

Thanks dmandrioli for the report. Looks like the fix was not complete.

comment:5 Changed 8 years ago by ykami

Resolution: fixed
Status: reopenedclosed

In [28630]:

Fixes #15203 Use scrollable.findDisp() when the given node is not SwapView?. !strict

Note: See TracTickets for help on using tickets.