Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#15200 closed defect (fixed)

FilteringSelect: entries are not highlighted on mouseover

Reported by: André Wessel Owned by: Douglas Hays
Priority: undecided Milestone: 1.7.3
Component: Dijit - Form Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

Hi everybody,

I have noticed that the onmouseover-highlighting of the entries of a FilteringSelect? doesn't work if any theme except claro is chosen. Also the highlighting of the textfield of the FilteringSelect? doesn't occur.

Can be reproduced with the theme-tester: http://download.dojotoolkit.org/release-1.7.2/dojo-release-1.7.2/dijit/themes/themeTester.html?theme=tundra

Greetings, André

Change History (6)

comment:1 Changed 10 years ago by Douglas Hays

Milestone: tbd1.7.3
Status: newassigned

Started with [23974]

comment:2 Changed 10 years ago by Douglas Hays

Resolution: fixed
Status: assignedclosed

In [28390]:

Fixes #15200. Selected was separated from Hover in 1.7 but the legacy themes need an extra CSS rule.

comment:3 in reply to:  2 Changed 10 years ago by André Wessel

Thank you for the quick reaction!

Highlighting of the textfield on mouseover is still missing.

Last edited 10 years ago by André Wessel (previous) (diff)

comment:4 Changed 10 years ago by Douglas Hays

AWessel, I don't see any hover effects on the main textbox area in tundra for any previous release. Can you append a screenshot of a before and after-hover screen-capture from a previous release?

comment:5 Changed 10 years ago by André Wessel

It isn't like I have seen it in the past / in a prior release. The Claro theme highlights the textbox of a FilteringSelect? onmouseover like it highlights the textbox of a Select. And I just thought that Tundra should behave similar to Claro concerning highlighting.

comment:6 Changed 10 years ago by Douglas Hays

That's a separate enhancement, but a wontfix since we're no longer enhancing the legacy themes. It's straightforward to add custom CSS to your own STYLE tag to achieve the desired hover effect.

Note: See TracTickets for help on using tickets.