Opened 8 years ago

Closed 8 years ago

#15192 closed defect (fixed)

Pie Chart with Two Equal Slices Errors When Rendering Labels

Reported by: Stovek Owned by: cjolif
Priority: undecided Milestone: 1.7.3
Component: Charting Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

Having a 50/50 pie chart is erroring only when Labels are being rendered (labelStyle of "columns" and labelWiring of "ccc").

Error occurs in pie.js when _calculateLabelR() is called from within the _getProperLabelRadius function. The firstSlice parameter is null because leftMinSIN equals tempSIN and rightMinSIN equals tempSIN, so firstSlice is never set.

Attachments (1)

test_pie2d_5050.html (1.8 KB) - added by cjolif 8 years ago.
example that reproduces the problem

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by cjolif

Attachment: test_pie2d_5050.html added

example that reproduces the problem

comment:1 Changed 8 years ago by cjolif

Owner: changed from Eugene Lazutkin to cjolif
Status: newassigned

comment:2 Changed 8 years ago by cjolif

Milestone: tbd1.7.3

comment:3 Changed 8 years ago by cjolif

In [28373]:

refs #15192. Fixes pie label issue + some dojo styleguide formatting + a test case. !strict.

comment:4 Changed 8 years ago by cjolif

In [28374]:

refs #15192.

comment:5 Changed 8 years ago by cjolif

Resolution: fixed
Status: assignedclosed

In [28375]:

fixes #15192. Backporting the fix to 1.7.X. !strict.

Note: See TracTickets for help on using tickets.