Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15188 closed defect (fixed)

dojox/gesture/tap sometimes fire exceptions

Reported by: cjolif Owned by: Evan
Priority: undecided Milestone: 1.8
Component: Dojox Version: 1.7.0
Keywords: Cc:
Blocked By: Blocking:

Description

This was found on trunk. I don't know if the problem exist in 1.7.x.

When you register a tap event, and you touch one finger and then quickly a second one on the screen _without_ removing the fingers from the screen you get an exception in _isTap because data.context is null.

It comes from the fact that when you touch the screen with your second finger the press method is deleting data.context but _not_ clearing the timeout that will call _isTap later on and access the data.context.

Attached in a small patch for this issue.

(this is reproducible on mobileCharting demo)

Attachments (1)

15188.patch (446 bytes) - added by cjolif 7 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 7 years ago by cjolif

Component: GeneralDojox
Milestone: tbd1.8
Owner: set to Adam Peller

comment:2 Changed 7 years ago by cjolif

Owner: changed from Adam Peller to Evan
Status: newassigned

Changed 7 years ago by cjolif

Attachment: 15188.patch added

comment:3 Changed 7 years ago by Evan

Resolution: fixed
Status: assignedclosed

In [28802]:

Fixes #15188, thanks cjolif!

Also back ported to 1.7.x branch

Last edited 7 years ago by Evan (previous) (diff)

comment:4 Changed 7 years ago by Evan

Version: 1.7.0
Note: See TracTickets for help on using tickets.