Opened 7 years ago

Closed 7 years ago

#15162 closed defect (duplicate)

Setting ItemFileReadStore to DataGrid using setStore() rapidly errors out

Reported by: shivaku_99@… Owned by:
Priority: undecided Milestone: tbd
Component: DojoX Grid Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

I am trying to set ItemFileReadStore? to DataGrid? rapidly using setStore(store), it errors out after few times setStore() is called.

I have a GridA and GridB. On selection of row in GridA I am populating values in GridB using GridB.setStore(). When I rapidly select rows in GridA, at some point of time I see error in console (ItemFileReadStore?: Invalid item argument) and the Grid Does not display any data at all, even the yellow rectangle. When I looked at the HTML i see the data but not displayed in Grid.

Change History (2)

comment:1 Changed 7 years ago by shivaku_99@…

looks like duplicate of 13635. But can you release a patch for 1.6.1?

comment:2 Changed 7 years ago by bill

Component: GeneralDojoX Grid
Resolution: duplicate
Status: newclosed

Duplicate of #13635.
You can ask for a backport on that ticket if you want, but I don't know if you'll get it.

Note: See TracTickets for help on using tickets.