Opened 8 years ago

Closed 8 years ago

#15158 closed defect (duplicate)

getComputedStyle - Opera Dragonfly error

Reported by: dojonovice@… Owned by:
Priority: undecided Milestone: tbd
Component: General Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

getComputedStyle property throws an error in Opera Dragonfly.

Uncaught exception: Error: WRONG_THIS_ERR

Error thrown at line 15, column 1316 in <anonymous function: req.has>(_19) in http://ajax.googleapis.com/ajax/libs/dojo/1.7.1/dojo/dojo.js: ....

Sample demo

<!DOCTYPE html> <html>

<head>

<title>getComputedStyle</title> <meta charset="utf-8"/> <link rel="StyleSheet?" type="text/css" href="http://ajax.googleapis.com/ajax/libs/dojo/1.7.1/dijit/themes/claro/claro.css"/> <script src="http://ajax.googleapis.com/ajax/libs/dojo/1.7.1/dojo/dojo.js" type="text/javascript" data-dojo-config="parseOnLoad:true, async:1"></script>

</head> <body class="claro">

<h3>getComputedStyle</h3> <script>

require(["dojo/ready", "dojo/dom-style", "dojo/query"], function(ready, domStyle, query) {

ready(function() {

var node = query("h3")[0]; console.dir(domStyle.getComputedStyle(node));

});

});

</script>

</body>

</html>

Change History (1)

comment:1 Changed 8 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #15096.

Note: See TracTickets for help on using tickets.