Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#15152 closed task (duplicate)

dojo.attr not working on IE6/8 for xml dom node

Reported by: kadudare Owned by:
Priority: undecided Milestone: tbd
Component: General Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

dojo.attr is not working for me on IE7/8 to retrieve an attribute from an xml dom node (with dojo 1.6.1).
FF/Chrome/Opera/Safari returns the correct data, but I.E. returns this error:

message : Wrong number of arguments or invalid property assignment,
number : -2146827838,

This is my simplified xhrGet code:

dojo.xhrGet({
	url: "commerce/xml-items.xml",
	handleAs: "xml",
	sync: true,
	load: function(xml){
		console.log(dojo.query("phase", xml).attr("label"));
	},
	error: function (error) {
		console.error('Error: ', error);
	}
});

We have another ticket opened relating the same issue, but it's been open for 3 years without a solution, and I wanted to bring it back to the top

Any help is very appreciated,
Thanks in advance!!!

Change History (2)

comment:1 Changed 8 years ago by ben hockey

Resolution: duplicate
Status: newclosed

Duplicate of #9628.
even though #9628 hasn't had any action in a while - this is definitely a duplicate of that ticket. we have >1500 open tickets right now so in order to manage our open tickets i'm closing this one in favor of that one.

comment:2 Changed 8 years ago by kadudare

Shame on you, 3 years and not even an answer...

Here is mine: use .getAttribute instead:

dojo.query("box phase",xml)[1].getAttribute('label')

Thanks to Michael Santelia!

Note: See TracTickets for help on using tickets.