Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1515 closed defect (duplicate)

Dojo fails to load in Mozilla for XML pages with <?xml-stylesheet type="text/xsl" href="..xsl" ?>

Reported by: ornus Owned by: dylan
Priority: high Milestone:
Component: General Version: 0.3
Keywords: Cc: sol@…
Blocked By: Blocking:

Description

With modern browsers it's possible to feed them XML page with a reference to an XSL stylesheet (through <?xml-stylesheet type="text/xsl" href="..xsl" ?>). When browser loads xml it then generates html using specified xsl.

In this scenario unbaked dojo fails to load in Mozilla. Baked dojo loads, but doesn't run *dj_load_init*. Everything works fine in IE.

I suspect the problem is due to the *DOMContentLoaded* event. I think it fires once when XML is loaded, prior to the transformation and HTML loading. Thus when dojo is loaded some of the events don't fire.

I realize that this approach speed everything up, but it doesn't always work. Maybe it would be better to allow developer specify onload approach to take through dj_config?

I'm going to include test example. It works in IE, but breaks in Mozilla. In this test when the page is loaded an alert should pop-up.

Attachments (1)

xmlLoadTest.zip (745 bytes) - added by ornus 13 years ago.
Test case. Unzip next to dojo.js (baked or not). When page loads an alert should pop-up. Works in IE, but fails in Mozilla.

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by ornus

Attachment: xmlLoadTest.zip added

Test case. Unzip next to dojo.js (baked or not). When page loads an alert should pop-up. Works in IE, but fails in Mozilla.

comment:1 Changed 13 years ago by dylan

Owner: changed from anonymous to dylan
Status: newassigned

comment:2 Changed 13 years ago by dylan

Resolution: duplicate
Status: assignedclosed

Duplicate of http://trac.dojotoolkit.org/ticket/501 (workaround is listed there). We should probably add this to the FAQ or docs.

comment:3 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.