Opened 7 years ago

Closed 4 years ago

Last modified 4 years ago

#15149 closed defect (fixed)

dojox/form/DateTextBox with popupclass not closing on Cancel

Reported by: Andrej Minarik Owned by: dylan
Priority: low Milestone: 1.8.11
Component: DojoX Form Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

When using dojox/form/DateTextBox with MonthAndYearlyCalendar? (as in the sample http://dojotoolkit.org/reference-guide/1.7/dojox/form/DateTextBox.html#dojox-form-datetextbox), the popup's Cancel button doesn't close the popup.

Steps to reproduce:

  1. open popup calendar on DateTextBox?
  2. pick a date, close popup either with OK or with Cancel button
  3. open the popup again, pick another date, click Cancel (now the popup doesn't close)

Markup:

<span data-dojo-type="dojox/form/DateTextBox" data-dojo-props="popupClass:'dojox.widget.MonthAndYearlyCalendar', constraints:{datePattern: 'MMMM yyyy'}"></span>

js:

require([
	"dojo",
	"dojo/ready",
	"dojox/form/DateTextBox",
	"dojox/widget/MonthAndYearlyCalendar"
], function(dojo, ready) {
	ready(function() {  

	});
});

Attachments (1)

calendar.patch (431 bytes) - added by Andrej Minarik 7 years ago.
suggested patch in _CalendarBase.js correcting the behaviour

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by Andrej Minarik

Attachment: calendar.patch added

suggested patch in _CalendarBase.js correcting the behaviour

comment:1 Changed 4 years ago by dylan

Milestone: tbd1.11
Owner: changed from dante to dylan
Status: newassigned

comment:2 Changed 4 years ago by dylan

Priority: undecidedlow

I hope to get to this ticket in time for 1.11 (setting a deadline of end of January). If not, this will get moved to 1.12.

comment:3 Changed 4 years ago by dylans <dylan@…>

Resolution: fixed
Status: assignedclosed

In b1ac047906c8fdb2331287c0154b5d896c3d601b/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:4 Changed 4 years ago by dylans <dylan@…>

In eaf179343a8b23eb16900e494188d0ed214ce40a/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:5 Changed 4 years ago by dylans <dylan@…>

In 06126f0179d10382de2055775a351a9592bb221c/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:6 Changed 4 years ago by dylans <dylan@…>

In f38f9057dfb23c84074574cc86218aeda5cb85c0/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:7 Changed 4 years ago by dylan

Milestone: 1.111.8.11

comment:8 Changed 4 years ago by dylan

#17981 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.