Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#15144 closed enhancement (fixed)

[patch][ccla]dojo/i18n: provide property to indicate loaded locale

Reported by: Adam Peller Owned by: Rawld Gill
Priority: low Milestone: 1.9
Component: Loader Version: 1.7.2
Keywords: Cc: atkin@…, yoshito_umaoka@…, Colin Snover
Blocked By: Blocking:

Description (last modified by Adam Peller)

The patch provides a $locale property on resource modules loaded by the dojo/i18n! loader plugin to indicate the most specific locale match (as opposed to the locale requested) which may vary from one module to the next. This can be useful for introspection, for example, when applying plural rules, which depend on the language actually used, not the user's default setting.

Attachments (1)

locale.patch (1.3 KB) - added by Adam Peller 8 years ago.
this patch sets the property on an Array object to return to the caller... not ideal

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by Adam Peller

Attachment: locale.patch added

this patch sets the property on an Array object to return to the caller... not ideal

comment:1 Changed 8 years ago by Adam Peller

Cc: atkin@… yoshito_umaoka@… added

comment:2 Changed 8 years ago by Adam Peller

Description: modified (diff)

comment:3 Changed 8 years ago by Adam Peller

Defaults to undefined for the root locale, which doesn't give the caller any idea what that langauge is.

comment:4 Changed 8 years ago by ben hockey

#15143 is a duplicate of this ticket.

comment:5 Changed 8 years ago by Rawld Gill

Milestone: tbd1.8
Priority: undecidedlow
Status: newassigned

comment:6 Changed 7 years ago by Colin Snover

Milestone: 1.82.0

1.8 is frozen. Move all enhancements to next release. If you need an exemption from the freeze for this ticket, contact me immediately.

comment:7 Changed 7 years ago by Adam Peller

Cc: Colin Snover added

Rawld, any chance we could get this in 1.8 in its current form? If it's more involved, we should certainly wait

comment:8 Changed 7 years ago by Rawld Gill

Resolution: fixed
Status: assignedclosed

typo in commit message: [30928] was for this ticket.

comment:9 Changed 7 years ago by Adam Peller

Milestone: 2.01.9

Thanks, Rawld!

Note: See TracTickets for help on using tickets.