Opened 7 years ago

Closed 7 years ago

#15116 closed defect (invalid)

dojox.mobile.ListItem not responding correctly on Android

Reported by: Marketware Owned by: Marketware
Priority: undecided Milestone: tbd
Component: DojoX Mobile Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

This issue relates to trunk. When I build a menu (see code below) the list items appear to respond fine on all PC browsers. However, when I attempt to access them on an Android phone (Incredible) they seem to require a "double tap" to respond.

Here is the code:

var ListMenuView? = new dojox.mobile.ScrollableView?({id: "ListMenuView?", selected: false, keepScrollPos: true }); dojo.body().appendChild(ListMenuView?.domNode); var k1333383852611 = new dojox.mobile.Heading({id: "k1333383852611", label: "Select List Category", fixed: "top", back: "View List", moveTo: "ListView?"}); ListMenuView?.addFixedBar(k1333383852611); k1333383852611.startup(); var listcat0 = new dojox.mobile.RoundRectList?({id: "listcat0"}).placeAt(ListMenuView?.containerNode); listcat0.startup(); var k1333383852612 = new dojox.mobile.ListItem?({id: "k1333383852612", label: "Activity", moveTo: "ActivityListMenuView?"}).placeAt(listcat0.containerNode); k1333383852612.startup(); var k1333383852613 = new dojox.mobile.ListItem?({id: "k1333383852613", label: "Demographics", moveTo: "DemographicsListMenuView?"}).placeAt(listcat0.containerNode); k1333383852613.startup(); var k1333383852614 = new dojox.mobile.ListItem?({id: "k1333383852614", label: "Issues", moveTo: "IssuesListMenuView?"}).placeAt(listcat0.containerNode); k1333383852614.startup(); ListMenuView?.startup();

Thank you for looking into this.

Bob Bartel, MarketWare?

Change History (5)

comment:1 Changed 7 years ago by ben hockey

Owner: changed from ykami to Marketware
Status: newpending

i tried to make a working example out of this code. here's what i've come up with http://jsfiddle.net/neonstalwart/GRagg/

if you want to look at it on a mobile device, try http://jsfiddle.net/neonstalwart/GRagg/embedded/result/

bob, i don't have an android device. can you confirm that the problem exists in the test case i've made? if not, can you suggest how i should change the example to demonstrate the problem - i removed a few of the startup calls that weren't completely necessary but ideally they shouldn't have hurt. however, i purposely took them out to see if they may be part of the cause of this problem. if you don't have the problem i'll work on adding them back to see if they make a difference.

comment:2 Changed 7 years ago by ben hockey

i went ahead and added a version with what would seem to be the equivalent startup calls in the original snippet http://jsfiddle.net/neonstalwart/GRagg/2/ and http://jsfiddle.net/neonstalwart/GRagg/2/embedded/result/ for mobile

comment:3 Changed 7 years ago by ben hockey

also, i had a colleague try both links with an Android 2.3 device and couldn't find an issue so bob i'm going to need some feedback about how to make a complete test case that fails.

comment:4 Changed 7 years ago by ykami

Could you try it again with the latest trunk? #15107 may be related to this problem.

comment:5 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.