Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15114 closed defect (wontfix)

dijit.ContentPane and IE7: Pane shows horizontal scrollbar althoug there is no need for that

Reported by: Paul Christopher Owned by:
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

Description

I'm having some issues with IE7 and dijit.ContentPane inside a TabContainer: The content pane shows a horizontal scrollbar although there is no need for that.

Steps to reproduce the issue

Run the attached testcase with IE9. Press F12 so as to open the debug console. Change browser mode to IE7. Reload the page. Notice: Tab "My first tab" has no scrollbar. Change to the tab "My second tab" and back to "My first tab". For some unknown reason, "My First tab" has a horizontal scrollbar now.

Affected browsers

IE7 (tested via IE9's IE7 mode only)

Discussion

I use conditional style sheets so as to hide the horizontal bar for IE7. But I do also use dojox.scrollIntoView for the pane. If scrollIntoView is performed, the pane starts to move horizontically. Therefore it is apperent for the user that the content pane is bigger than actually needed.

All in all a minor issue, but an issue, users will notice first since the application behaves strangely.

Attachments (2)

testContentPane.html (2.7 KB) - added by Paul Christopher 7 years ago.
workaround.html (2.5 KB) - added by bill 7 years ago.
avoids the problem by removing intermediate ContentPane?

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by Paul Christopher

Attachment: testContentPane.html added

comment:1 Changed 7 years ago by bill

Resolution: wontfix
Status: newclosed

Looks like an IE bug, and not sure how to fix it. But you can workaround it by eliminating that redundant ContentPane. See the workaround file I attached.

A more complicated workaround would probably be to setup a resize() method on your custom widget.

Changed 7 years ago by bill

Attachment: workaround.html added

avoids the problem by removing intermediate ContentPane?

comment:2 Changed 7 years ago by Paul Christopher

Bill, thank you very much for looking into this! I'll give the workaround a try. IE7 is really a pain sometimes...

Note: See TracTickets for help on using tickets.