Opened 7 years ago

Closed 6 years ago

#15113 closed defect (invalid)

[patch] [cla] dojox.widget.Dialog does not resize layout children correctly - Fix provided

Reported by: kbenjamin Owned by: kbenjamin
Priority: undecided Milestone: 1.9
Component: DojoX Widgets Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

When the Dialog contains widgets with a resize() function they do not consistently resize due to the animation effects used in Dialog.

The solution is to wait to call resize until after the animations have completed.

My customized dojox/widget/Dialog wrapper is attached but the code could be easily added and integrated into dojox/widget/Dialog.

Attachments (1)

CustomDojoxDialog.js (1.3 KB) - added by kbenjamin 7 years ago.
dojox.widget.Dialog wrapper to fix resize bugs.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by kbenjamin

Attachment: CustomDojoxDialog.js added

dojox.widget.Dialog wrapper to fix resize bugs.

comment:1 Changed 6 years ago by kbenjamin

CLA on file.

comment:2 Changed 6 years ago by bill

Summary: dojox.widget.Dialog does not resize layout children correctly - Fix provided[patch] [cla] dojox.widget.Dialog does not resize layout children correctly - Fix provided

Would be better if this were an actual patch file. Also, if the problem is with Dialog animations, then why do you need a delay on window resize? Does window resize cause the Dialog to animate?

comment:3 Changed 6 years ago by dylan

Milestone: tbd1.9
Owner: changed from dante to kbenjamin
Status: newpending

Ken, if you create an updated patch against 1.9 (as an actual patch), we'll review and consider for inclusion.

comment:4 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.