Opened 8 years ago

Closed 8 years ago

#15099 closed defect (duplicate)

Dijit and Event Bubbling with dojo/on

Reported by: Kitson Kelly Owned by:
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

It appears that Dijit's and dojo/on don't behave as expected when stopping event bubbling when there is a native DOM event as well.

A working example of the problem is available at: http://jsfiddle.net/TEJsq/

Both

event.stop(evt);

and

e.stopPropagation();

Don't stop the on("click") from bubbling to any underlying divs. But the event does get modified, losing it clientX and clientY values.

Change History (1)

comment:1 Changed 8 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #15097.

Note: See TracTickets for help on using tickets.