Opened 8 years ago

Closed 8 years ago

#15094 closed defect (worksforme)

ComboBox: clicking outside of ComboBox doesn't cause blur event

Reported by: marcules Owned by: marcules
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

If you create a DropDown with the ComboBox-Element, and you open said DropDown, after clicking either on a dropdown-element or somewhere else outside the dropbox, but not in an element which itself seeks focus (like input), the focus is not released as expected. You have to click an additional time outside the dropdown, so the box looses its focus.

This could be fixed with a blur() after the function which closes the dropdown is fired.

Change History (4)

comment:1 Changed 8 years ago by bill

Description: modified (diff)
Summary: dijit.form.ComboBox general focus errorComboBox: clicking outside of ComboBox doesn't cause blur event

comment:2 Changed 8 years ago by Douglas Hays

Owner: changed from Douglas Hays to marcules
Status: newpending

Please attach a testcase. I changed test_Button.html and added a ComboBox? to the dropdown Menu of the Edit! button and it seemed to close the dropdown when I clicked away.

comment:3 Changed 8 years ago by marcules

Status: pendingnew

Cannot reproduce outside internal project. Please close, till I can reproduce.

comment:4 Changed 8 years ago by Douglas Hays

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.