Opened 7 years ago

Closed 7 years ago

#15041 closed defect (invalid)

Memory Leaks in IE8 - destroyRecursive on widget is not releasing widget resources.

Reported by: smedagam Owned by: smedagam
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

Calling destroyRecusrive() method on widget is not releasing widget resources in IE8 despite widget implementing uninitialize method to remove all allocated internal resources. What do we need to do in order to clean up/destroy all allocated widget resources?

Also we are using dGrid to display results from a Memory store. Do we need to call any specific method on the store to clean the store before destroying the widget?

Change History (2)

comment:1 Changed 7 years ago by bill

Component: GeneralDijit
Owner: set to smedagam
Status: newpending

You'll need to attach a test case using the "attach file" button. It should be as small as possible to still reproduce the problem, ideally a single HTML file. And also, instructions on how to reproduce the problem using that test file.

For questions, please use the dojo-interest mailing list.

comment:2 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.