Opened 7 years ago

Closed 7 years ago

#15039 closed defect (fixed)

dojox.mobile.TabBarButton: DOM exception in IE9

Reported by: Adrian Vasiliu Owned by: ykami
Priority: high Milestone: 1.8
Component: DojoX Mobile Version:
Keywords: Cc:
Blocked By: Blocking:

Description

The setter of the "badge" property of dojox.mobile.TabBarButton? raises in IE9 the following error: SCRIPT5022: DOM Exception: NOT_FOUND_ERR (8) TabBarButton?.js, line 232 character 6

This is because, when the value is null or undefined, the setter tries to remove an unexisting child. The call of domNode.removeChild is safe everywhere but in IE9.

How to reproduce:

  1. Launch dojox/mobile/tests/
  2. Press the "Search" button (on the bottom) three times.

==> The error quoted above shows-up in IE9. (Works fine in other desktop and mobile browsers).

Patch attached.

Attachments (1)

patch-15039-dojox.mobile.TabBarButton.txt (500 bytes) - added by Adrian Vasiliu 7 years ago.
Adrian Vasiliu, IBM, CCLA

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by Adrian Vasiliu

Adrian Vasiliu, IBM, CCLA

comment:1 Changed 7 years ago by Adrian Vasiliu

Adding the missing test name in the first step of "how to reproduce": dojox/mobile/tests/test_TabBar-badge.html

comment:2 Changed 7 years ago by ykami

Milestone: tbd1.8
Priority: undecidedhigh
Status: newassigned

comment:3 Changed 7 years ago by ykami

Resolution: fixed
Status: assignedclosed

In [28215]:

Fixes #15039 !strict. Thanks Adrian for the patch. The root cause was that, on IE, _getBadgeAttr returned some value even after the badge was removed from the document. I fixed that problem. I also applied your patch. It was necessary too.

Note: See TracTickets for help on using tickets.