Opened 7 years ago

Closed 7 years ago

#15036 closed defect (fixed)

Tabbbing through elements on a Dijit Dialog does not work correctly

Reported by: amathias Owned by: bill
Priority: undecided Milestone: 1.8
Component: Dijit Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description

If I have a Dijit Dialog that contains a number of form elements on it, each with a tab index specified, when I tab through the elements the 9th tab press always sends me back to the first element on the dialog box.

This appears to be caused by the walkTree function defined inside dijit._getTabNavigable in a11y.js. It is grabbing the tabindexes from the elements, which are strings, and then comparing them using < and >= as if they were integers. Since "10" >= "9" returns false, it doesn't set that element as the highest. The end result is that the item with tabindex 9 is set as the highest element even if I have 30 or 50 elements on the page.

Change History (2)

comment:1 Changed 7 years ago by bill

Milestone: tbd1.8
Owner: set to bill
Status: newassigned

Ah good catch, I'll fix.

comment:2 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

In [28200]:

Make sure to treat tabindex as number, not string, so comparisons work correctly, fixes #15036 !strict.

Note: See TracTickets for help on using tickets.