Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15030 closed defect (fixed)

Error null object when dijit/Editor is contained in dijit/form/Form in IE7 >9

Reported by: Jovanovic Owned by: Douglas Hays
Priority: undecided Milestone: 1.8
Component: Editor Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

With Dojo 1.7.2, when widget dijit/Editor is contained in dijit/form/Form error message appear in IE9 console : SCRIPT5007: Impossible d’obtenir la valeur de la propriété « document » : objet null ou non défini _WidgetBase.js, Ligne 2 Caractère 4628

Example code :

<!DOCTYPE html PUBLIC "-W3CDTD XHTML 1.0 TransitionalEN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns="http://www.w3.org/1999/xhtml">

<head> <title>Test</title>

<meta http-equiv="Content-Type" content="text/html;charset=utf-8" />

<script>

dojoConfig= {

has: {

"dojo-firebug": true

}, parseOnLoad: true,

isDebug: true,

async:true

};

</script> <script src="http://ajax.googleapis.com/ajax/libs/dojo/1.7.2/dojo/dojo.js" type="text/javascript"></script>

<style type='text/css'> @import 'http://ajax.googleapis.com/ajax/libs/dojo/1.7.2/dijit/themes/claro/claro.css'; </style> </head>

<body class="claro"> <b>Toggle the View Source button to see the contents in source mode.</b> <br> <form method="post" data-dojo-type="dijit.form.Form"> <div data-dojo-type="dijit.Editor" id="editor" style="width:98%; height: 450px;"> test </div> </form> </body>

</html> <script> require([

"dojo/parser", "dijit/form/Form",

"dijit/Editor"

]); </script>

Attachments (1)

test2.html (1.0 KB) - added by Jovanovic 7 years ago.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by Jovanovic

Attachment: test2.html added

comment:1 Changed 7 years ago by Douglas Hays

Component: Dijit - FormEditor
Milestone: tbd1.8
Status: newassigned

Editor isn't fully initialized on startup() and get('value') is throwing the exception.

comment:2 Changed 7 years ago by Douglas Hays

Resolution: fixed
Status: assignedclosed

In [28187]:

Fixes #15030. Avoid exception in _stripBreakerNodes if called before onLoad. !strict

comment:3 Changed 7 years ago by bill

#15134 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.