Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1503 closed defect (fixed)

[regression] latest TabContainer (5813) broken for user created new tabs

Reported by: rob@… Owned by: bill
Priority: high Milestone:
Component: Widgets Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

I have the latest trunk and noticed that the latest commit has changed TabContainer? to extend PageContainer?. Something in this change has broken the layout for user created tabs (e.g. click on a tree item and a new tab is created). It is broken in that the new tab's ContentPane? does not size correctly -- it displays as if there is no sizeShare or styling.

Before, I had a tab created like so: var focusTabFrame = document.createElement("iframe"); focusTabFrame.setAttribute("id", tabId); focusTab = dojo.widget.createWidget("ContentPane?", {label: _label, widgetId: tabId, sizeShare: 100}, focusTabFrame);

This worked fine (the iframe filled the container). Since the update, newly added frames/tab-pages displayed at a default, non filling size. I fixed this in FF by adding: focusTabFrame.setAttribute("style", "width:100%;height:100%;");

But, I can't seem to do anything to affect newly added tabs in IE.

--- a bit more info --- Say I have opened 3 tabs. The first one opens correctly, filling the container. The next one opens to not fill and same with the 3rd. If I click back on the 2cnd tab, it fills the container this time. But if I click back on the 3rd it is still at the non-filling size. This happens consistently in that it is always the last tab that is at its non-filling size no matter how tabs I open.

How to fix?

Attachments (2)

test_dynamic_tabs.html (3.7 KB) - added by guest 13 years ago.
possible-tabcontainer-bug.png (113.7 KB) - added by attila.lendvai@… 13 years ago.

Download all attachments as: .zip

Change History (7)

Changed 13 years ago by guest

Attachment: test_dynamic_tabs.html added

Changed 13 years ago by attila.lendvai@…

comment:1 Changed 13 years ago by attila.lendvai@…

i'm not sure it's completly related, but this bug also appeared around the same checkin. please see the attached png, and the related part of the html:

<div id="main-tab-container-widget" dojo:type="TabContainer" dojo:dolayout="FALSE" dojo:closebutton="tab"
  ><div id="main-tab-container"
  ><div id="main-menu-widget" dojo:type="ContentPane" label="Menu"
  ><div class="treemenu" id="main-menu"
  ><div class="links"
    ><ol

i may be doing something wrong, the extra div is for ajax purposes: the framework renders a stub (id="main-tab-container") that can be later replaced by a freshly rendered version from an XHTTP request.

but it was working fine before a recent checking.

comment:2 Changed 13 years ago by dylan

Milestone: 0.4
Summary: latest TabContainer (5813) broken for user created new tabs[regression] latest TabContainer (5813) broken for user created new tabs
Version: 0.40.3

comment:3 Changed 13 years ago by attila.lendvai@…

fyi, the bug visible in my .png attachment seems to be solved in svn head. no idea about the originally attached test-case, though.

thanks!

  • attila

comment:4 Changed 13 years ago by bill

Resolution: fixed
Status: newclosed

All should be fixed now (try test_LayoutCode.html as a testcase too)

comment:5 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.