Opened 7 years ago

Closed 7 years ago

#15027 closed defect (invalid)

Dijit.form submit is not submitting (posting) the last entered field value, on form submit

Reported by: mangaya Owned by: mangaya
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

Consider a dijit.Form inside a dijit.Dialog with username(dijit.form.validateTextBox) and password(dijit.form.validateTextBox) field in it.

Steps: enter username, press tab and enter password. Keeping the focus inside the password field hit enter and submit the form. Only the username is posted not the password. But if the password field onBlur event is fired and if we hit the enter button to submit the form then the username and password both are submitted properly.

Basically the last entered field value is not submitted properly on form submit

Attachments (3)

Ticket 15027.txt (1.9 KB) - added by mangaya 7 years ago.
logon.html (1.3 KB) - added by mangaya 7 years ago.
LogonDlg.js (2.2 KB) - added by mangaya 7 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 7 years ago by bill

Component: DojoX FormDijit - Form
Owner: changed from dante to mangaya
Status: newpending

Presumably you mismarked the component on this. Also, please attach a test case to every ticket, including this one.

Changed 7 years ago by mangaya

Attachment: Ticket 15027.txt added

comment:2 Changed 7 years ago by mangaya

Status: pendingnew

Attachment (Ticket 15027.txt) added by ticket reporter.

comment:3 Changed 7 years ago by bill

Status: newpending

Not a code snippet. A test case is an HTML file that can be loaded in the browser to reproduce the problem.

Changed 7 years ago by mangaya

Attachment: logon.html added

comment:4 Changed 7 years ago by mangaya

Status: pendingnew

Attachment (logon.html) added by ticket reporter.

Changed 7 years ago by mangaya

Attachment: LogonDlg.js added

comment:5 Changed 7 years ago by bill

Status: newpending

@mangaya - What are the exact instructions to reproduce the problem, using your test files?

comment:6 in reply to:  5 Changed 7 years ago by mangaya

Status: pendingnew

Replying to bill:

@mangaya - What are the exact instructions to reproduce the problem, using your test files?

Steps:

  1. enter the value for "first name", hit tab
  2. enter the value for "last name" and then immediately press "Enter" to submit the form. Do not use the button to submit the form
  3. Then the "last name" value is not submitted by form. FORM.value does not hold the "last name" value in it.
  4. The value is submitted only when the onBlur() event is fired for the dijit.form.ValidateTextBox?

comment:7 Changed 7 years ago by bill

Status: newpending

@mangaya - Your logon.html test case is invalid, it doesn't even load dojo, nor does it load your logon.js file. And it has a syntax error. You need to attach a valid test case.

comment:8 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.