Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15016 closed defect (fixed)

Tooltip: after/before position broken in claro

Reported by: Karl Tiedt Owned by: bill
Priority: undecided Milestone: 1.7.3
Component: Dijit Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

http://downloads.dojotoolkit.org/release-1.7.2/dojo-release-1.7.2/dijit/themes/themeTester.html

Expand the Popups and Alerts accordion, then mouse over the before/after tooltip areas... the arrows are not connected positioned to the tooltip

Change History (10)

comment:1 Changed 7 years ago by bill

Milestone: tbd1.7.3
Summary: dijit.Tooltip after/before position broken in claroTooltip: after/before position broken in claro

This keeps coming up, see #14701 and #14976. I already documented that tooltip position needs to be after-centered/before-centered, but for back-compat I'll add some code to convert after/before to after-centered/before-centered.

comment:2 Changed 7 years ago by bill

Owner: set to bill
Status: newassigned

comment:3 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

In [28168]:

Get after/before to work for Tooltip again, fixes #15016 on trunk !strict.

comment:4 Changed 7 years ago by bill

In [28169]:

Get after/before to work for Tooltip again, fixes #15016 on 1.7 branch !strict.

comment:5 Changed 7 years ago by Karl Tiedt

I saw those actually, and [27718] sounds like before/after *should* work like they used to (which would be expected for backwards-compat) based on the commit message.

comment:6 Changed 7 years ago by Karl Tiedt

Bill, is it safe to say that "above/below/before/after" are all deprecated and no longer officially supported? If so we might want to include mapping above/below the same way you did before/after

If so then I'll refrain from mentioning the next thing we noticed involving above-centered + above.

comment:7 Changed 7 years ago by bill

Hmm, well I'm recommending above-centered/below-centered rather than above/below as I think they look nicer, but I wasn't thinking so far as deprecated. Although maybe I'll change my mind when I hear the problem you are having.

I could do the mapping like you suggested but I was a little worried someone might want the old behavior, where the left side of the tooltip is aligned with the left side of the anchor node. I think that alignment looks good (or normal?) for TooltipDialog on desktop. I know TooltipDialog is a different widget than Tooltip, but still something to think about for comparison.

comment:8 Changed 7 years ago by Karl Tiedt

I didnt find a test in ThemeTester? that reproduced this but if you have a above-centered tooltip and display it, then display a above tooltip the connector is stil "centered" due to this if block located here:

http://bugs.dojotoolkit.org/browser/dojo/dijit/trunk/Tooltip.js#L106

if you add an else { this.connectorNode.style.left = ""; } the problem goes away.

comment:9 Changed 7 years ago by bill

Makes sense, thanks, I'll add that.

comment:10 Changed 7 years ago by bill

In [28192]:

Fix problem where if you have a above-centered tooltip and display it, then display a above tooltip the connector is stil "centered". Refs #15016 !strict.

Note: See TracTickets for help on using tickets.