Opened 7 years ago

Closed 7 years ago

#15013 closed defect (fixed)

dojox.mobile.ViewController: transitions broken in some browsers

Reported by: Adrian Vasiliu Owned by: ykami
Priority: high Milestone: 1.8
Component: DojoX Mobile Version:
Keywords: Cc:
Blocked By: Blocking:

Description

The mobile view transitions are broken in some browsers. Reproduced in Firefox 10 on desktop using dojo-trunk as of 14 March 2012. Works fine in other desktop and mobile browsers.

How to reproduce:

  1. Launch dojox/mobile/tests/test_new_transition-animations.html in Firefox (tested in FF10).
  2. Click any item.

=> No transition.

Patch attached.

The bug exists in dojo-trunk since rev. 27594 of dojox/mobile/ViewController.js. The bug is NOT present in the 1.7.2 branch.

Attachments (1)

patch15013.txt (551 bytes) - added by Adrian Vasiliu 7 years ago.
Adrian Vasiliu, IBM, CCLA

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by Adrian Vasiliu

Attachment: patch15013.txt added

Adrian Vasiliu, IBM, CCLA

comment:1 Changed 7 years ago by ykami

Milestone: tbd1.8
Priority: undecidedhigh
Status: newassigned

comment:2 Changed 7 years ago by ykami

Resolution: fixed
Status: assignedclosed

In [28218]:

Fixes #15013 !strict. Fixed a typo, event -> evt. Thanks Adrian for the patch.

Note: See TracTickets for help on using tickets.