Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#15010 closed defect (fixed)

Dialog: _onShow gets called twice due to the initial layout causing a node resize (IE7)

Reported by: DJ Mountney Owned by: bill
Priority: undecided Milestone: 1.6.3
Component: Dijit Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

Repro Code:

var dialog = new dijit.Dialog({content: 'Testing', onShow: function(){alert('Show');}});
dialog.startup();
dialog.show();

The second _onShow is being called by the resize() method in ContentPaneResizeMixin?

The first _onShow calls layout(), which ends up causing this.domNode.onresize to fire in IE7 before this._wasShown is set to true at the end of _onShow() in the ContentPaneResizeMixin?

Also reproed in 1.7.2

Change History (6)

comment:1 Changed 10 years ago by bill

Summary: In MSIE 7, _onShow gets called twice on dijit.Dialogs due to the initial layout causing a node resizeDialog: _onShow gets called twice due to the initial layout causing a node resize (IE7)

I'll try to reproduce but in the future please attach test cases using the "attach file" button, thanks.

Version 0, edited 10 years ago by bill (next)

comment:2 Changed 10 years ago by bill

Owner: set to bill
Resolution: fixed
Status: newclosed

In [28193]:

Make sure onShow() only called once on initial show, fixes #15010 !strict.

comment:3 Changed 10 years ago by bill

Milestone: tbd1.8

Thanks twk3, it was like you said.

comment:4 Changed 8 years ago by Bill Keese <[email protected]…>

In 4fe91bf57e806bcce95aef863193018f6125ad93/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:5 Changed 8 years ago by Bill Keese <[email protected]…>

In 9321666a6bc736b027c1987b66c3e1941477b2e4/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:6 Changed 8 years ago by bill

Milestone: 1.81.6.3
Note: See TracTickets for help on using tickets.