Opened 10 years ago

Closed 10 years ago

#15003 closed defect (duplicate)

Fix for #6812/Interpolate property has issue when the first point is null

Reported by: cheewe Owned by: Adam Peller
Priority: undecided Milestone: tbd
Component: Dojox Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

Thanks for the wonderful fix to #6812(http://bugs.dojotoolkit.org/changeset/27625/dojo). I love it. One behavior that was changed with this latest patch is if the first point is null, nothing is drawn. So in your example, this works exactly what you expected it

var seriesB = [2, 3, null, null, 4, 5, null, 6, 7];

But

var seriesB = [null, 2, 3, null, null, 4, 5, null, 6, 7];

doesn't render at all. In fact,

var seriesB = [null, 2, 3, 4, 5, 6, 7];

rendered before, but not with the latest patch.

Change History (1)

comment:1 Changed 10 years ago by Adam Peller

Resolution: duplicate
Status: newclosed

Duplicate of #6812.
dup of #6812

Note: See TracTickets for help on using tickets.