Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#14992 closed defect (fixed)

405 (Method Not Allowed) error in chrome

Reported by: Jovanovic Owned by: Adam Peller
Priority: undecided Milestone: 1.8
Component: Dojox Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

In 1.7, when plugins dojox/editor/plugins/TablePlugins is required with a CDN, a 405 error appear in Chrome :

OPTIONS http://ajax.googleapis.com/ajax/libs/dojo/1.7.2/dojox//editor/plugins/resources/insertTable.html 405 (Method Not Allowed) XMLHttpRequest cannot load http://ajax.googleapis.com/ajax/libs/dojo/1.7.2/dojox//editor/plugins/resources/insertTable.html. Origin http://localhost is not allowed by Access-Control-Allow-Origin. OPTIONS http://ajax.googleapis.com/ajax/libs/dojo/1.7.2/dojox//editor/plugins/resources/modifyTable.html 405 (Method Not Allowed) XMLHttpRequest cannot load http://ajax.googleapis.com/ajax/libs/dojo/1.7.2/dojox//editor/plugins/resources/modifyTable.html. Origin http://localhost is not allowed by Access-Control-Allow-Origin.

With Firefox, error is : Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE)" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: http://ajax.googleapis.com/ajax/libs/dojo/1.7.2/dojo/dojo.js :: <TOP_LEVEL> :: line 15" data: no] http://ajax.googleapis.com/ajax/libs/dojo/1.7.2/dojo/dojo.js Line 15

Attachments (1)

test2.html (486 bytes) - added by Jovanovic 8 years ago.

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by Jovanovic

Attachment: test2.html added

comment:1 Changed 8 years ago by Adam Peller

Resolution: fixed
Status: newclosed

In [28132]:

more AMD. Fixes #14992, refs #11939

comment:2 Changed 8 years ago by Adam Peller

Milestone: tbd1.8

comment:3 Changed 8 years ago by Jovanovic

I'm searching a fix to use this plugins. Do you know if exist any solution to use this with a dojo 1.7 CDN ? Thanks

comment:4 Changed 8 years ago by Adam Peller

unfortunately, as it stands, this fix will not be deployed until 1.8

Note: See TracTickets for help on using tickets.