Opened 7 years ago

Closed 7 years ago

#14989 closed defect (fixed)

[cla][patch] dojo/i18n does not wait for localization preloads to complete before fetching nls bundles

Reported by: Colin Snover Owned by: Rawld Gill
Priority: blocker Milestone: 1.7.3
Component: Internationalization Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking: #14092

Description

Related to #14972. dojo/i18n doesn’t wait for preloadLocalizations to successfully retrieve bundles before requesting the i18n modules which means too many requests occur. Patch attached against 1.7 branch.

Attachments (1)

ticket-21394-2.diff (1.8 KB) - added by Colin Snover 7 years ago.

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by Colin Snover

Attachment: ticket-21394-2.diff added

comment:1 Changed 7 years ago by Rawld Gill

Status: newassigned

comment:2 Changed 7 years ago by Rawld Gill

Resolution: fixed
Status: assignedclosed

In [28127]:

hold nls bundle resolution until all preloadLocationization bundles are on board; thanks csnover; fixes #14989; !strict

comment:3 Changed 7 years ago by bill

Milestone: 1.7.31.8

comment:4 Changed 7 years ago by Colin Snover

Milestone: 1.81.7.3
Resolution: fixed
Status: closedreopened

I put specific milestones on my tickets for a reason, Bill :)

comment:5 Changed 7 years ago by bill

It doesn't seem worth backporting to me, but in any case it's Rawld's decision which loader fixes are critical enough and safe enough to backport to the 1.7 branch. He just checked this one into the trunk.

comment:6 Changed 7 years ago by Colin Snover

Status: reopenedassigned

comment:7 Changed 7 years ago by Nick Fenwick

Is this problem related to #15090?

comment:8 Changed 7 years ago by Nick Fenwick

Sorry, ignore me. #15090 is probably just a dup of this, and seems to be fixed on trunk.

comment:9 Changed 7 years ago by ben hockey

#15090 is a duplicate of this ticket.

comment:10 Changed 7 years ago by Rawld Gill

Resolution: fixed
Status: assignedclosed

I'm transferring tracking backport to 1.7 of this ticket to #14092. The i18n fixes will either be backported in total or not at all since there is too much risk trying to backport a subset.

Note: See TracTickets for help on using tickets.