Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#14987 closed defect (fixed)

[regression] stripConsole build parameter is ignored when building with Rhino

Reported by: tommahieu Owned by: Rawld Gill
Priority: undecided Milestone: 1.8
Component: BuildSystem Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

the stripConsole build profile parameter seems to be ignored. This only happens when building with Rhino.

Technical summary: when building the compile function in the writeOptimized transform module, the stripConsoleRe variable is only assigned a value when running on node (i.e. has("host-node") evaluates to true).

It is always undefined in the case has("host-rhino") code branch is executed. Applying attached patch resolves the issue by defining stripConsoleRe before attempting to build any one of the rhino or node compilation algorithms.

Attachments (1)

writeOptimized.patch (1.4 KB) - added by tommahieu 8 years ago.
define stripConsoleRe before building a compile method

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by tommahieu

Attachment: writeOptimized.patch added

define stripConsoleRe before building a compile method

comment:1 Changed 8 years ago by cjolif

Component: GeneralBuildSystem
Owner: set to Rawld Gill

comment:2 Changed 8 years ago by Kenneth G. Franqueiro

Milestone: tbd1.7.3
Summary: stripConsole build parameter is ignored when building with Rhino[regression] stripConsole build parameter is ignored when building with Rhino

comment:3 Changed 8 years ago by Rawld Gill

Resolution: fixed
Status: newclosed

In [28317]:

fixes #14987; !strict, thanks tommahieu

comment:4 Changed 8 years ago by bill

Milestone: 1.7.31.8

Since this was just fixed in trunk, not the 1.7 branch, changing milestone to reflect that. (It's not a critical issue anyway since there's a workaround of using closure.)

Note: See TracTickets for help on using tickets.