Opened 10 years ago

Closed 10 years ago

#14971 closed defect (fixed)

demos/touch: severe regression when running with Dojo 1.8 (dojo-trunk)

Reported by: Adrian Vasiliu Owned by: Evan
Priority: undecided Milestone: 1.8
Component: General Version: 1.7.2
Keywords: Cc: cjolif
Blocked By: Blocking:

Description

Updates are needed in demos/touch to fix a severe regression when running with dojo-trunk (Dojo 1.8).

Reproduced with http://svn.dojotoolkit.org/src/view/anon/all/trunk as of 6 March 2012.

How to reproduce:

Launch demos/touch/demo.html in any browser. => The pie chart is simply not there. The console shows: "Uncaught TypeError?: Cannot read property 'generateGradient' of undefined"

Attachments (1)

ticket14971.patch (1.3 KB) - added by Adrian Vasiliu 10 years ago.
Adrian Vasiliu, IBM, CCLA

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by Adrian Vasiliu

Attachment: ticket14971.patch added

Adrian Vasiliu, IBM, CCLA

comment:1 Changed 10 years ago by Adrian Vasiliu

I forgot to mention the second regression (less important) in the same demo:

How to reproduce:

  1. Launch demos/touch
  2. Click the "Hold down to lock" button (you need to stay clicked for a few seconds)

=> The "lock" icon doesn't show-up and the console shows: GET http:/Launch demos/touch/demo.html in any browser./9.128.82.71:8020/dojo-trunk/demos/touch/images/icon-lock 404 (Not Found)

Both issues (the above one and the one mentioned in the "description") are fixed in the attached patch.

Last edited 10 years ago by Adrian Vasiliu (previous) (diff)

comment:2 Changed 10 years ago by bill

Milestone: tbd1.8
Owner: set to Evan
Status: newassigned

Evan, looks like your name is on that demo, guess this is for you.

comment:3 Changed 10 years ago by cjolif

Cc: cjolif added

comment:4 Changed 10 years ago by Evan

Resolution: fixed
Status: assignedclosed

In [28113]:

Fixes #14971, thanks very much for the fix patch from Adrian Vasiliu(IBM, CCLA)

Note: See TracTickets for help on using tickets.