Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#14958 closed defect (duplicate)

[regression] dojox image Gallery does not work in dojo 1.7.2

Reported by: tbeauvais Owned by: Rawld Gill
Priority: undecided Milestone: 1.7.3
Component: BuildSystem Version: 1.7.2
Keywords: Cc: Colin Snover, Kenneth G. Franqueiro
Blocked By: Blocking:

Description

The dojox image Gallery does not work in dojo 1.7.2, this does work in 1.7.1.

Hitting this test page works for Dojo 1.7.1 http://download.dojotoolkit.org/release-1.7.1/dojo-release-1.7.1/dojox/image/tests/test_Gallery.html

Hitting this test page works fails for Dojo 1.7.2 http://download.dojotoolkit.org/release-1.7.2/dojo-release-1.7.2/dojox/image/tests/test_Gallery.html

There are no useful errors in the JavaScript? console. It appears that just doing a dojo.require of dojox.image.Gallery breaks dojo on the page.

Change History (7)

comment:1 Changed 8 years ago by Adam Peller

Cc: Colin Snover Kenneth G. Franqueiro added
Owner: changed from Adam Peller to Shane O'Sullivan
Status: newassigned

comment:2 Changed 8 years ago by bill

Component: DojoxBuildSystem

Probably Rawld should be looking at this, because it works fine from source, just not from a build.

I did my build in the 1.7 branch (latest code) with:

./build.sh  --releaseDir /workspace/1.7release --profile standard copyTests=true --release
Last edited 8 years ago by bill (previous) (diff)

comment:3 Changed 8 years ago by Adam Peller

Milestone: tbd1.7.3
Summary: The dojox image Gallery does not work in dojo 1.7.2 dojox/image/tests/test_Gallery.html[regression] dojox image Gallery does not work in dojo 1.7.2

comment:4 Changed 8 years ago by Adam Peller

Owner: changed from Shane O'Sullivan to Rawld Gill

comment:5 Changed 7 years ago by Rawld Gill

Resolution: duplicate
Status: assignedclosed

The root cause of the problem is identical to that identified and fixed in #14808. I verified the error in 1.7.2 and the fix in trunk. #14808 will likely be backported; but we'll track this issue on that ticket.

Marking as dup/resolved.

comment:6 Changed 7 years ago by Adam Peller

The fix for #14808 seems to have already been checked into the 1.7 branch. Since it's difficult to track closed tickets, if an issue remains for the 1.7 branch, we should open/reopen a ticket.

comment:7 in reply to:  6 Changed 7 years ago by Rawld Gill

Replying to peller:

The fix for #14808 seems to have already been checked into the 1.7 branch. Since it's difficult to track closed tickets, if an issue remains for the 1.7 branch, we should open/reopen a ticket.

Yep, my comment was confusing/wrong: #14808 has been backported and this ticket is fully solved on both 1.7 branch and trunk.

Note: See TracTickets for help on using tickets.