Opened 8 years ago

Closed 6 years ago

Last modified 6 years ago

#14950 closed defect (fixed)

ToggleDir and ToggleDir_rtl test failures on IE9

Reported by: bill Owned by: Bill Keese <bill@…>
Priority: undecided Milestone: 1.8
Component: Editor Version: 1.7.2
Keywords: dohfail Cc:
Blocked By: Blocking:

Description

expected
		.
	but got

Change History (8)

comment:1 Changed 8 years ago by bill

Keywords: dohfail added

comment:3 Changed 8 years ago by haysmark

I think it has to do with rtl being rendered differently in IE than other browsers (rtl with ltr language is undefined?)

comment:4 Changed 7 years ago by bill

Could be. It's definitely acting strangely. If I click the toggle button and then click anywhere in the sentence, the caret immediately jumps to the end of the sentence.

comment:5 Changed 6 years ago by bill

Problem with the caret jumping still happens on trunk (essentailly, 1.10 beta) on IE9. The caret doesn't jump on IE10 though. Presumably the regression test is still failing on IE9 too although I'm having trouble running any regression tests on IE9 now; some problem with robot I think.

comment:6 Changed 6 years ago by bill

Milestone: tbd1.8
Resolution: fixed
Status: newclosed

Oh actually this seems to be fixed starting in 1.8, and the caret jumping problem is fixed starting with 0e535339c4baf60630e718e09cd8d49ec7069f22 in 1.10.

comment:7 Changed 6 years ago by Bill Keese <bill@…>

Owner: set to Bill Keese <bill@…>

In 86cd0479595d25478e67ead1128c3d23ef6c0e85/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:8 Changed 6 years ago by bill

Woops, the last check in was for #17653.

Note: See TracTickets for help on using tickets.