Opened 8 years ago

Closed 4 years ago

#14941 closed defect (invalid)

NodeList-FX onEnd fires once per match not once per query

Reported by: Karl Tiedt Owned by: Kris Zyp
Priority: undecided Milestone: tbd
Component: Query Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

Maybe this is by design but it sure seems like a bug

x = 0; dojo.query("div").fadeOut({onEnd: function() {console.log(x++); }}).play()

This will cause log() to fire once per div on the page...

Change History (1)

comment:1 Changed 4 years ago by dylan

Resolution: invalid
Status: newclosed

Not a bug, the intent of these items on a query is to iterate over each item. A fadeOut would indeed happen per div, and the effect is per node.

I think you would need to use the full fx API if you wanted to just have one event after all items have faded out.

Note: See TracTickets for help on using tickets.