Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#14931 closed enhancement (duplicate)

try to make themes look consistent when border-box is applied

Reported by: ben hockey Owned by:
Priority: undecided Milestone: 1.9
Component: Dijit - LnF Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

http://paulirish.com/2012/box-sizing-border-box-ftw/ encourages the use of border-box by applying the following style

* {
    -moz-box-sizing: border-box;
    box-sizing: border-box;
}

border-box is a more intuitive box model and so i can see that its likely developers will follow this advice.

if you look at themeTester with this setting, you'll see that the widgets are affected by this. we should look into seeing what we can do about it. we might even find that it could be possible to leverage border-box.

Change History (5)

comment:1 Changed 8 years ago by bill

See also #15104, I'm guessing that blocks this ticket but not sure.

comment:2 Changed 7 years ago by bill

Milestone: tbd1.9

comment:3 Changed 7 years ago by bill

Amazingly it works pretty well (at least in trunk). I see layout problems for:

  • TabContainer scrolling buttons
  • space to the left and right of tabs; can be seen clearly by clicking on a dark color on the ColorPicker in the accordion
  • slight problem with up/down arrow buttons on NumberSpinner

comment:4 Changed 7 years ago by bill

Resolution: duplicate
Status: newclosed

Telling dojo/dom-geometry that your page is in box-model setting fixes all the problems except the tiny NumberSpinner layout glitch.

Would be nice if you didn't need to do that, which I noted in #15104.

Closing as duplicate of #15104.

Last edited 7 years ago by bill (previous) (diff)

comment:5 Changed 7 years ago by bill

In [30685]:

code to test border-box sizing, refs #14931, #15104

Note: See TracTickets for help on using tickets.