Opened 8 years ago

Closed 7 years ago

#14923 closed defect (fixed)

inconsistent theming for arrow buttons

Reported by: ben hockey Owned by: bill
Priority: undecided Milestone: 1.9
Component: Dijit - LnF Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

when number spinner and select are focused, the arrow buttons are a shade of blue but filtering select, combo box, date text box, time text box (are there more?) are a shade of gray.

fwiw, i like the blue.

Change History (4)

comment:1 Changed 8 years ago by bill

Blue sounds good to me, do you have a patch?

comment:2 Changed 7 years ago by bill

Milestone: tbd1.9

comment:3 Changed 7 years ago by bill

Owner: set to bill
Status: newassigned

I like the blue too, but it turns out that's the hover color. In other words, when NumberSpinner or Select is focused, it's as though those arrow buttons are being hovered even though they aren't. For NumberSpinner, from this rule:

.claro .dijitSpinnerFocused .dijitArrowButton {
	background-color: @arrowbutton-hovered-background-color;
}

You could make a stretch argument that it makes sense semantically, since the user is poised to effectively click those arrow buttons by pressing the keyboard's up/down arrow keys.

I'll assume that was the intended behavior for all widgets, and update ComboBox etc. to match. It looks nicer aesthetically, except for a ComboBox in an error state, where the blue button clashes with the red border.

Note though that I'm just talking about the arrow button's background color. The color of the arrow itself still changes based on actual hover effect.

comment:4 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

In [29915]:

Make ComboBox etc. more consistent with NumberSpinner and Select, by making the arrow background turn to it's hover color whenever the ComboBox is focused. Fixes #14923 !strict.

Note: See TracTickets for help on using tickets.