Opened 8 years ago

Closed 7 years ago

#14919 closed enhancement (fixed)

Mobile ValuePicker needs theming

Reported by: ykami Owned by: Eric Durocher
Priority: undecided Milestone: 1.8
Component: DojoX Mobile Version: 1.7.2
Keywords: Cc: cjolif
Blocked By: Blocking:

Description

Currently the value picker has only android-style look and feel. Styles for other platforms are necessary.

Attachments (5)

dojox.patch (11.5 KB) - added by Soyhy Lim 7 years ago.
Patch for iPhone theme
dojox.2.patch (7.3 KB) - added by Soyhy Lim 7 years ago.
Soyhy Lim (IBM, CCLA): Second version of theme for iPhone + Firefox compat-css
dojox-ticket_14919-version_03.patch (13.7 KB) - added by Soyhy Lim 7 years ago.
Soyhy Lim (IBM, CCLA):
dojox-ticket_14919-version_03.2.patch (13.7 KB) - added by Soyhy Lim 7 years ago.
Soyhy Lim (IBM, CCLA):
dojox-ticket_14919-version_03-png.zip (1.9 KB) - added by Soyhy Lim 7 years ago.
Soyhy Lim (IBM, CCLA): compatibility gradient images for some browser

Download all attachments as: .zip

Change History (14)

comment:1 Changed 8 years ago by bill

#14920 is a duplicate of this ticket.

comment:2 Changed 7 years ago by cjolif

Owner: changed from ykami to Eric Durocher
Status: newassigned

comment:3 Changed 7 years ago by cjolif

Cc: cjolif added

Changed 7 years ago by Soyhy Lim

Attachment: dojox.patch added

Patch for iPhone theme

comment:4 Changed 7 years ago by cjolif

In [28834]:

refs #14919. first draft iOS theme for data picker, some adjustment might be done later. Thanks Soyhy Lim (IBM, CCLA).

comment:5 Changed 7 years ago by cjolif

Milestone: tbd1.8

Changed 7 years ago by Soyhy Lim

Attachment: dojox.2.patch added

Soyhy Lim (IBM, CCLA): Second version of theme for iPhone + Firefox compat-css

comment:6 Changed 7 years ago by cjolif

In [28852]:

refs #14919. Improvments of theme for iPhone + Firefox compat-css. Thanks Soyhy Lim (IBM, CCLA).

Changed 7 years ago by Soyhy Lim

Soyhy Lim (IBM, CCLA):

Changed 7 years ago by Soyhy Lim

Soyhy Lim (IBM, CCLA):

Changed 7 years ago by Soyhy Lim

Soyhy Lim (IBM, CCLA): compatibility gradient images for some browser

comment:7 Changed 7 years ago by Soyhy Lim

I have attached the 3rd version of the patch, dojox-ticket_14919-version_03.patch, including the improvement for iOS theme + a BlackBerry? theme, and fallback images for IE.

  • In addition to the dojox-ticket_14919-version_03.patch file, Please unzip the dojox-ticket_14919-version_03-png.zip in dojox/
  • Please ignore dojox-ticket_14919-version_03.2.patch which is exactly the same thing as dojox-ticket_14919-version_03.patch

Thanks,

Soyhy Lim (IBM, CCLA)

comment:8 Changed 7 years ago by cjolif

In [28871]:

refs #14919. Theme for BlackBerry? + compat version. Thanks Soyhy Lim (IBM, CCLA).

comment:9 Changed 7 years ago by cjolif

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.