Opened 8 years ago

Closed 7 years ago

#14915 closed defect (invalid)

this.attr('value') is empty object, for Dijit Dialog

Reported by: mangaya Owned by: mangaya
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

I have dijit Form inside a dijit Dialog, Say if, this = Dijit.Dialog and when I request for this.attr('value') I used to get all value attribute for the childrens available inside the Dijit Dialog in previous version. But in Dojo 1.7.2 the this.attr('value') is empty. It is not getting all children information. On debugging I found that _FormMixin._getValueAttr() and _FormMixin._getDescendentFormWidget() does not return all the children available in the Dialog.

Attachments (1)

Ticket 14915.txt (2.4 KB) - added by mangaya 8 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 8 years ago by Douglas Hays

Please append a testcase. In what version did it work as you wanted?

comment:2 Changed 8 years ago by bill

Owner: changed from Douglas Hays to mangaya
Status: newpending

Changed 8 years ago by mangaya

Attachment: Ticket 14915.txt added

comment:3 Changed 8 years ago by mangaya

Status: pendingnew

Attachment (Ticket 14915.txt) added by ticket reporter.

comment:4 Changed 8 years ago by mangaya

See attachment for more information. In the attachment the line:59. this.attr('value').

Dojo 1.6.2 : we used to provide all the attributes value objects declared inside the dijit.form

DOJO1.7.2 : it just returns empty object.

Last edited 8 years ago by mangaya (previous) (diff)

comment:5 Changed 7 years ago by bill

Status: newpending

I see the text file you've attached, but I need for you to attach an actual test case. It should be as small as possible to still reproduce the problem, almost always a single HTML file that we can load in the browser and use to reproduce then problem.

Then, give exact instructions on how to reproduce the problem using your attached test file.

The test case is necessary both to confirm that there's a bug, and for us to be able to debug the problem.

Thanks!

comment:6 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.