Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#14914 closed defect (fixed)

dojox.form.Uploader problem with MID declaration in markup

Reported by: Joso Owned by: Mike Wilcox
Priority: undecided Milestone: 1.9
Component: DojoX Uploader Version: 1.7.2rc1
Keywords: Cc:
Blocked By: Blocking:

Description

I cannot declare dojox.form.Uploader as dojox/form/Uploader in markup syntax.

It works only in old style: dojox.form.Uploader.

Current supported state

<input id="uploader" name="uploadedfile" type="file" data-dojo-type="dojox.form.Uploader" data-dojo-props="label:'someText'" />

wanted state

<input id="uploader" name="uploadedfile" type="file" data-dojo-type="dojox/form/Uploader" data-dojo-props="label:'someText'" />

Change History (5)

comment:1 Changed 7 years ago by ben hockey

this is probably related to #14811

comment:2 Changed 7 years ago by bill

Summary: problem with MID declaration in markupdojox.form.Uploader problem with MID declaration in markup

comment:3 Changed 6 years ago by Mike Wilcox

Milestone: tbd1.9
Resolution: fixed
Status: newclosed

This is fixed. I converted Uploader to use AMD properly which required discarding the plugin approach. All functionality is now included in Uploader. plugins remain for backcompat in order to throw warnings.

comment:4 Changed 6 years ago by bill

For the record: (In [30328]) Fixes: #14768, #15151, #16293, #14914, #14811, #11885, #14075 converted Uploader to use AMD properly which required discarding the plugin approach. All functionality is now included in Uploader. plugins remain for backcompat in order to throw warnings.

comment:5 Changed 6 years ago by ben hockey

#16864 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.