Opened 7 years ago

Closed 7 years ago

#14905 closed defect (invalid)

ScrollableView does not work in Windows Phone 7

Reported by: cyrus-smith Owned by: ykami
Priority: undecided Milestone: tbd
Component: DojoX Mobile Version: 1.7.2
Keywords: Cc: Eric Durocher
Blocked By: Blocking:

Description

We've found that ScrollableView? does not scroll when run on Windows Phone. Tests were made on emulator and on real device Sansung Omnia W (Windows Phone 7.5) To reproduce, just create vertical list, wrapped with <div data-dojo-type="dojox.mobile.ScrollableView?">

Change History (8)

comment:1 Changed 7 years ago by ykami

Oh, you are the first one who tried dojox.mobile on Windows Phone. :)
Out of curiosity, how were the other widgets on Windows Phone?
What version of dojo did you use? The trunk code, or 1.7.x?
Another interest is quality of the emulator. What do you think about reproducibility of the emulator?

comment:2 Changed 7 years ago by cyrus-smith

Emulator displays UI much the same as real device. Widgets looks not so smooth as on android or ios. They are functional except for the scrollable bug.

comment:3 Changed 7 years ago by bill

BTW Cyrus, can you tell me the output of http://bill.dojotoolkit.org/trunk/hasTest.html on a Windows7 phone? It's meant for webkit only but I'm curious how well IE/mobile stacks up.

comment:4 Changed 7 years ago by cyrus-smith

Here's emulators output for hasTest:

userAgent: Mozilla/5.0 (compatible; MSIE 9.0; Windows Phone OS 7.5; Trident/5.0; IEMobile/9.0; Microsoft; XDeviceEmulator) appVersion: 5.0 (compatible; MSIE 9.0; Windows Phone OS 7.5; Trident/5.0; IEMobile/9.0; Microsoft; XDeviceEmulator)

Differences from expected values for webkit: ie: expected = undefined, actual: 9 event-orientationchange: expected = true, actual: false events-mouseenter: expected = false, actual: true touch: expected = true, actual: false

comment:5 Changed 7 years ago by bill

OK, thanks, looks like IE is running as well as webkit (or at least, can use more-or-less the same profile as webkit).

comment:6 Changed 7 years ago by cyrus-smith

I've made some investigation of event handling in WP7 browser. It appears that IE9 on WP7 does not support touch event. Instead, one should use old good onmousedown and onmousemove (on touch device!). Another bad news is that IE9 Mobile does not distinguish between onmousedown and onmousemove events. It looks like one can scroll only using native browser capabilities

comment:7 Changed 7 years ago by ykami

That's too bad.. but thank you for the investigation.

comment:8 Changed 7 years ago by cjolif

Cc: Eric Durocher added
Resolution: invalid
Status: newclosed

We don't and we won't support WP7 so I'm closing that one as invald as we don't claim support. That said we will support WP8 in 1.9. See #16175.

Note: See TracTickets for help on using tickets.