Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#14904 closed defect (fixed)

dijit.Form.Filtering Select and JSON REST store: Missing range-header on Opera browsers

Reported by: Paul Christopher Owned by: Kris Zyp
Priority: undecided Milestone: 1.8
Component: Data Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

Description

Refering to http://dojo-toolkit.33424.n3.nabble.com/FilteringSelect-paging-using-a-JsonRest-store-in-Dojo-1-7-td3770061.html I want to report, that a FilteringSelect using a JSON REST store might not work correctly on Opera browsers when a pageSize is set: On Opera browsers, the range header is missing on the server side. Therefore paging cannot be performed. This is some kind of blocker since you usually use a JSON REST store for large amounts of data which cannot be returned to the client but using pages.

Steps to reproduce the issue

Set up a FilteringSelect using a JSON REST store. Set a pageSize. Test it on several browsers. For me it only works fine on Firefox10, IE9, Safari5. It is also reported that it works fine for Chrome, see mail above. However it does not work for Opera: The range header is completely missing there.

Discussion

Yet unclear what causes this behaviour. I use Dojo 1.7.2. and an ASP.net application. Don't know whether this is a bug on the server side or on the client side. I cannot debug this further, since Fiddler2 does not pick up my local traffic to the ASP.net development server CASSINI. May someone more experienced can have a quick look at that and can exclude the suspicions that this is a Dojo bug.

Change History (7)

comment:1 Changed 8 years ago by Douglas Hays

Component: Dijit - FormData
Owner: Douglas Hays deleted
Status: newassigned

comment:2 Changed 8 years ago by Paul Christopher

UPDATE "Behaviour seems to be independent of server side solution"

Refering again to the above discussion on the mailing list: This behaviour seems to be server side independent. It happens to me with an ASP.net based RESTful service, to James Shaw with a PHP5 based one.

comment:3 Changed 8 years ago by Douglas Hays

Owner: set to Kris Zyp

comment:4 Changed 8 years ago by Kris Zyp

Resolution: fixed
Status: assignedclosed

In [28039]:

Add X-Range header for Opera since it blocks the Range header, fixes #14904
Avoid duplicate question marks in the query !strict

comment:5 Changed 8 years ago by bill

Milestone: tbd1.8

comment:6 Changed 8 years ago by Paul Christopher

Thank you very much for fixing this so quickly. That's great! :-))

comment:7 Changed 8 years ago by Paul Christopher

I have just tested this with the latest nightly code. It works nicely. However I could not find any hint in the livedocs (e.g. http://livedocs.dojotoolkit.org/dojo/store/JsonRest) that on the server side you need to check not just for "range" but "x-range", too.

Note: See TracTickets for help on using tickets.