Opened 7 years ago

Closed 6 years ago

#14884 closed enhancement (fixed)

the noref switch should be autoset truthy when the compat switch is 1.6 on a layer

Reported by: Rawld Gill Owned by: Rawld Gill
Priority: low Milestone: 1.9
Component: BuildSystem Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

Since noref must be truthy in order for compat==="1.6" to work correctly, this should be handled automatically.

Change History (5)

comment:1 Changed 7 years ago by Rawld Gill

Milestone: tbd1.8
Priority: undecidedlow
Status: newassigned

comment:2 Changed 7 years ago by Colin Snover

Milestone: 1.82.0

1.8 is frozen. Move all enhancements to next release. If you need an exemption from the freeze for this ticket, contact me immediately.

comment:3 Changed 7 years ago by bill

Except that when 2.0 comes, there won't be any compat==="1.6" anymore (whatever that is), right? Maybe you want to close as wontfix? I'm not sure.

comment:4 Changed 6 years ago by Rawld Gill

Milestone: 2.01.9

This is super-low-risk and being fixed in a way that can be overridden. Getting it done.

comment:5 Changed 6 years ago by Rawld Gill

Resolution: fixed
Status: assignedclosed

In [31283]:

set noref true if compat is 1.6 by default; still allow profile to explicitly override (though such an override would be odd); fixes #14884; !strict

Note: See TracTickets for help on using tickets.