Opened 8 years ago

Closed 8 years ago

#14868 closed defect (invalid)

dijit.Layout: Dynamically appending content to a top region with splitter causes wired results

Reported by: Paul Christopher Owned by:
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

Description

Dynamically appending content to a content pane of border layout widget that has splitters causes wired results. After appending the content, the splitter is somehow broken.

Steps to reproduce the issue

Run the attached test case. Resize the top region to see the appended content. Watch the results.

Attachments (2)

index.html (1.3 KB) - added by Paul Christopher 8 years ago.
testLayout.html (1.3 KB) - added by Paul Christopher 8 years ago.

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by Paul Christopher

Attachment: index.html added

comment:1 Changed 8 years ago by Paul Christopher

Appending the content via dijit.ContentPane.set('content', newContent) does not work either, see testLayout.html.

Changed 8 years ago by Paul Christopher

Attachment: testLayout.html added

comment:2 Changed 8 years ago by Paul Christopher

I'm sorry for filing this ticket - it is invalid. Just calling resize() does the trick. I have just read the docs for BorderContainer and ContentPane but have not read the overall information given on the start page of dijit layout. Next time I need to test things more thoroughly before creating a ticket. Sorry! Keep up the good work!

comment:3 Changed 8 years ago by bill

Resolution: invalid
Status: newclosed

No worries. That's right, you need to call BorderContainer.resize() because otherwise the BorderContainer doesn't know that the ContentPane changed size.

Note: See TracTickets for help on using tickets.