Opened 7 years ago

Closed 7 years ago

#14865 closed defect (fixed)

The right margin returned by dojo.getMarginExtents is incorrect

Reported by: siqi Owned by:
Priority: undecided Milestone: 1.8
Component: HTML Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description

Copy the test file 'test_getMarginExtents.html' to 'dojo/tests/' and open it in chrome. The right margin should be 6px while the value returned via getMarginExtents is 8px.

The issue is caused by following codes in dom-geometry.js, seems it is intended to fix an issue in Safari.

		if(has("webkit") && (s.position != "absolute")){
			// FIXME: Safari's version of the computed right margin
			// is the space between our right edge and the right edge
			// of our offsetParent.
			// What we are looking for is the actual margin value as
			// determined by CSS.
			// Hack solution is to assume left/right margins are the same.
			r = l;
		}

Attachments (1)

test_getMarginExtents.html (464 bytes) - added by siqi 7 years ago.

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by siqi

Attachment: test_getMarginExtents.html added

comment:1 Changed 7 years ago by bill

Component: CoreHTML
Milestone: tbd1.8
Resolution: fixed
Status: newclosed

Fixed in [27852].

Note: See TracTickets for help on using tickets.