Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#14860 closed defect (invalid)

Tooltips on Pie charts appearance broken

Reported by: marrow16 Owned by: cjolif
Priority: undecided Milestone: 1.7.3
Component: Charting Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

Applying tooltips to Pie charts - when the tooltip appears the arrow part of the tooltip appears in the wrong place and seems detached from the tooltip. See attached image. Examining the DOM - it can be observed that the @class of the dijit master tooltip is being set to "dijitTooltip undefined". (Reverting to 1.7.1 fixes issue)

Attachments (1)

dojo pi chart tooltip issue.png (10.9 KB) - added by marrow16 7 years ago.

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by marrow16

comment:1 Changed 7 years ago by marrow16

Oops, this should be assigned to component 'Charting'

comment:2 Changed 7 years ago by Mike Wilcox

Owner: changed from Mike Wilcox to Eugene Lazutkin
Status: newassigned

comment:3 Changed 7 years ago by bill

Cc: cjolif added
Component: DojoX DrawingCharting
Owner: changed from Eugene Lazutkin to marrow16
Status: assignedpending

Can you attach a minimal test case?

comment:4 Changed 7 years ago by bill

PS: I do note that Tooltip.js should probably be saying ["above-centered", "below-centered"] wherever it now says ["above", "below"]. And similarly for ["before", "after"].

Last edited 7 years ago by bill (previous) (diff)

comment:5 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:6 Changed 7 years ago by bill

Milestone: tbd1.7.3
Resolution: invalid
Status: closedreopened

[28128] fixed some of this, but you probably also want to change ["above", "below"] to ["above-centered", "below-centered"] .

comment:7 Changed 7 years ago by bill

Cc: cjolif removed
Owner: changed from marrow16 to cjolif
Status: reopenedassigned

comment:8 Changed 7 years ago by cjolif

bill, you re-opened that bug on 1.7.2 (to be fixed in 1.7.3). But I don't reproduce at all the issue in 1.7.x branch (even though I did in trunk and thus the fixed above [28128]). I'm reluctant to change 1.7.x code while it is working for me? Also I don't have issues with the above/below position just the before/after.

comment:9 Changed 7 years ago by bill

Resolution: invalid
Status: assignedclosed

Oh you are right, I didn't look at the version numbers carefully. I'll re-close this as invalid, but you should probably still checkin to trunk to use ["above-centered", "below-centered"], even if there isn't a layout bug, just because it will make the tooltips appear centered.

comment:10 Changed 7 years ago by cjolif

ok, will do that. Thanks.

Note: See TracTickets for help on using tickets.