Opened 7 years ago

Closed 6 years ago

#14855 closed defect (fixed)

dojox.layout.GridContainer: grid columns aren't sized to height of grid container

Reported by: talisto Owned by: haysmark
Priority: undecided Milestone: 1.9
Component: DojoX Layout Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

Note: this is an issue with the git master/trunk (1.8.0) as of Feb 21, 2012, and is NOT an issue with the latest released version (1.7.2).

In 1.7.2 (and prior), the grid columns of a GridContainer? are equal to the height of the GridContainer? (expected behaviour). In the git trunk, the grid columns are equal to the height of the widgets in the column, even if the GridContainer? has a larger height.

Try the attached test case in both 1.7.2 and 1.8.0 (trunk). In 1.7.2, the background is entirely white, due to the columns (which are white) taking up the full height of the GridContainer? (which is blue). In 1.8.0 (trunk), the GridContainer?'s blue background is visible, because the columns are only taking up the height equal to the widget in the column.

Attachments (1)

gridcontainertest.html (870 bytes) - added by talisto 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by talisto

Attachment: gridcontainertest.html added

comment:1 Changed 7 years ago by talisto

this is still an issue with 1.8.0b1.

comment:2 Changed 7 years ago by talisto

this is also still an issue with 1.8.0rc1.

comment:3 Changed 6 years ago by haysmark

Owner: set to haysmark
Status: newassigned

This was AMD refactor fail in [26978]. Setter calls to marginBox were replaced with getMarginBox.

comment:4 Changed 6 years ago by haysmark

Milestone: tbd1.9
Version: 1.8.0

comment:5 Changed 6 years ago by haysmark

Resolution: fixed
Status: assignedclosed

In [30553]:

Fix regression where setter marginBox/contentBox calls were refactored to getMarginBox/getContentBox. Fixes #14855. Refs #14235. !strict

Note: See TracTickets for help on using tickets.