Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#14853 closed defect (fixed)

Select: Title tooltip not displayed in FireFox

Reported by: wskidmore Owned by: Douglas Hays
Priority: undecided Milestone: 1.8
Component: Dijit - Form Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description

If a title attributed is set on a dijit Select it is not displayed (upon mouse over) in major versions of FireFox? (tested 3.6, 8 and 10).

After some digging I've narrowed it down to this line:

Code highlighting:

  this.connect(this.domNode, "onmousemove", event.stop);

From dijit/form/Select.js.uncompressed line 294 (dojo 1.7.1). It is in the postCreate() function. Comment this line out and title attribute works as intended.

Research suggests that FF uses the mouse move event somehow to display the tooltip:

http://stackoverflow.com/questions/1004826/tooltips-title-wont-show-in-firefox

https://bugzilla.mozilla.org/show_bug.cgi?id=645305

There is a comment in Select.js saying that line is needed for IE, suggested fix is to put a if ( isIE ) before making the connect call.

Attachments (1)

title_defect_FF.html (762 bytes) - added by wskidmore 7 years ago.
Test case showing lack of tooltip in FF

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by wskidmore

Attachment: title_defect_FF.html added

Test case showing lack of tooltip in FF

comment:1 Changed 7 years ago by bill

Component: DijitDijit - Form
Owner: set to Douglas Hays
Summary: Title tooltip not displayed on dijit Select in FireFoxSelect: Title tooltip not displayed in FireFox

comment:2 Changed 7 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

In [27991]:

Fixes #14853. Stop selectstart events instead of mousemove to make Firefox tooltips work.

comment:3 Changed 7 years ago by Douglas Hays

Milestone: tbd1.8
Note: See TracTickets for help on using tickets.