Opened 7 years ago

Closed 7 years ago

#14847 closed defect (duplicate)

dojox.charting.action2d.Tooltip Issue

Reported by: pugalsrini Owned by: pugalsrini
Priority: undecided Milestone: tbd
Component: Charting Version: 1.7.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

There is an issue with the Chart Tooltip when the chart div location in the browser changes. When the chart div position changes, the charts within it moves to the new position, but the chart tooltip remains at the absolute position.

Here is the example below to test the situation.

  1. When the file is opened in a browser, the Column chart is shown. Hover over the column to see the tooltip.
  2. Click on the link. This will increase the height of the div above the Chart.
  3. The chart moves down,
  4. Hover over the Columns. The tooltip remains at the same place as before - way up the chart position.

Using disconnect/connect or new does not solve the issue. Is this a bug or am I missing the correct usage.

<script type="text/javascript">
    dojo.require("dojox.charting.Chart");
    dojo.require("dojox.charting.DataChart");
    dojo.require("dojox.charting.axis2d.Default");
    dojo.require("dojox.charting.action2d.Tooltip");
    dojo.ready(
        function initThisPage() {
             var chart = new dojox.charting.Chart("chartDiv");
             chart.addAxis("x", {natural: true});
             chart.addAxis("y", {vertical: true, fixLower: "major", fixUpper: "major", includeZero: true});
             chart.addPlot("default", {type: dojox.charting.plot2d.Columns});
             chart.addSeries("Series A",[1,3,6]);
             new dojox.charting.action2d.Tooltip(chart);
             chart.render();
    });
     function expandDiv(){
        dojo.style(dojo.byId('someDiv'),"height","250px");
    }

</script>


<div id="someDiv">
Click <a href="#" onclick="expandDiv();return false;">here</a> to expand this div<br>
The chart moves down, but the tooltip remains at the same absolute position.    
</div>
<div id="chartDiv" style="height:200px"></div>

Change History (5)

comment:1 Changed 7 years ago by Adam Peller

Component: DojoxCharting
Owner: changed from Adam Peller to Eugene Lazutkin

comment:2 Changed 7 years ago by bill

Description: modified (diff)

There's a known limitation w/dijit tooltips if you move the anchor while the tooltip is being shown. But you are saying that you moved the chart when the tooltip was hidden?

comment:3 Changed 7 years ago by cjolif

Owner: changed from Eugene Lazutkin to pugalsrini
Status: newpending

Are you sure you are experiencing this against 1.7.2 as specified in the ticket? Because this is a known 1.7 / 1.7.1 issue that was fixed in 1.7.2. Can you please verify your version and let us know?

Last edited 7 years ago by cjolif (previous) (diff)

comment:4 in reply to:  3 Changed 7 years ago by pugalsrini

Status: pendingnew

You are right. I am using 1.7.1 and not 1.7.2. I just knew I was using the latest dojo. I didn't realize that 1.7.2 is the latest. Thanks for the information and the fix. I will get the latest dojo.

Replying to cjolif:

Are you sure you are experiencing this against 1.7.2 as specified in the ticket? Because this is a known 1.7 / 1.7.1 issue that was fixed in 1.7.2. Can you please verify your version and let us know?

comment:5 Changed 7 years ago by cjolif

Resolution: duplicate
Status: newclosed
Version: 1.7.21.7.1

Duplicate of #14526.

Note: See TracTickets for help on using tickets.